Skip to content

Update httpie to use requests lib version >= 2.32.1 #1597

Open

Description

Current Issue:
The current httpie version 3.2.3 has a dependency on requests library and it requires requests version lib to be >=2.22.0 and<=2.31.0

Enhancement Request:
httpie needs to be updated to have dependency on requests lib version which is >= 2.32.1

Problem it solves:
requests lib version 2.31.0 is an old version and has few vulnerabilities. Downgrading httpie to 3.2.2 doesn't help either as it has some vulnerabilities as well and its recommended to use 3.2.3

Activity

  1. ghost added
    enhancementNew feature or enhancement
    on Sep 5, 2024
  2. ghost added
    newNeeds triage. Comments are welcome!
    on Sep 5, 2024
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    enhancementNew feature or enhancementnewNeeds triage. Comments are welcome!

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions